Plaftorm high latency
Incident Report for 360Learning
Resolved
The issue has been resolved. We apologize for any inconvenience caused by this incident
Posted Oct 13, 2023 - 10:32 CEST
Investigating
Our users are currently experiencing higher than normal load times on the Web application.
We're investigating the cause and will provide an update as soon as possible.
Posted Oct 13, 2023 - 10:05 CEST
This incident affected: Web Application.