Video Streaming Latency

Incident Report for 360Learning

Resolved

A fix has been applied successfully. The Videos are now playing normally.
We maintain reinforced monitoring to accompany this return to normal.
Posted Jul 10, 2025 - 10:11 CEST

Identified

Our Video Streaming is affected by performance issues.
You could have been affected by latency when playing video.
The issue is identified, and a fix is currently applied. We will monitor and communicate again in few minutes
Posted Jul 10, 2025 - 10:06 CEST
This incident affected: Web Application, Android App, and iOS App.